We have new information regarding the incident that affected your service(s).
Please find below an update on the situation: Update : As you know, a aws SDKs upgrade added a new cheksum enforcement. This upgrade leads in return of "InvalidArgument" on different Object operations. Since then, our development team has been working hard on support for this new checksum. This takes time because these developments affect data integrity checks. We are therefore taking every possible precaution by adding numerous Q&A tests to ensure that the fix's deployment is carried out without any impact. Ongoing Actions : The incident has been identified and our teams are mobilised to restore service as quickly as possible.
We will keep you updated on the progress and resolution. We apologize for any inconvenience caused and appreciate your understanding.
Posted Apr 25, 2025 - 13:42 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 17, 2025 - 06:51 UTC
Update
We have new information regarding the incident that affected your service(s).
Please find below an update on the situation: Update : We have completed our development and the fix is currently being tested in our Q&A process. Testing process is especially long to prevent any regression while fixing the issue. Ongoing Actions : The incident has been identified and our teams are mobilised to restore service as quickly as possible.
We will keep you updated on the progress and resolution. We apologize for any inconvenience caused and appreciate your understanding.
Posted Apr 10, 2025 - 08:46 UTC
Update
We have new information regarding the incident that affected your service(s).
Please find below an update on the situation: Update : Our teams are still working on fix.
We will keep you updated on the progress and resolution. We apologize for any inconvenience caused and appreciate your understanding.
Posted Mar 03, 2025 - 12:37 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 06, 2025 - 19:10 UTC
Identified
We have determined the origin of the incident affecting our Object Storage S3 offer.
Here are some supplementary details : Start time : 01/01/2025 00:00 UTC Impacted Service(s) : Object Storage S3 Customers Impact : Requests to our Object Storage endpoint could return the error "InvalidArgument", on different Object operations. Root Cause : Following a recent AWS SDK upgrade, this issue is due to a new checksum enforcement in those SDKs. Unsupported headers are: - x-amz-content-sha256 with value STREAMING-UNSIGNED-PAYLOAD-TRAILER - x-amz-sdk-checksum-algorithm with value CRC32 Workaround A workaround is to downgrade the version, until the feature is implemented on our side. Max supported versions: - boto3 1.35.99 - legacy aws cli 1.36.40 - aws cli 2.22.35 - aws-sdk-go 1.72.3 - aws-sdk-java 2.29.52 - aws-sdk-js-v3 3.726.1 - aws-sdk-net 3.7.962.0 - aws-sdk-php 3.336.15 - aws-sdk-ruby 1.177.0 Ongoing Actions : The incident has been identified and our teams are mobilized to restore service as quickly as possible.
We will keep you updated on the progress and resolution. We apologize for any inconvenience caused and appreciate your understanding.
Posted Jan 23, 2025 - 15:11 UTC
Investigating
We are currently experiencing an event affecting our Object Storage S3 offer. Start time : 01/01/2025 00:00 UTC
Our teams are fully committed to investigating this issue and working towards a resolution as soon as possible. As investigations are ongoing, we will share any new findings or updates with you as soon as possible.
We apologize for any inconvenience caused and appreciate your understanding.
Posted Jan 23, 2025 - 14:51 UTC
This incident affects: Storage || Object storage (BHS, GRA, DE, RBX, SBG, SGP, SYD, UK, US-EAST-VA-1, US-WEST-OR-1, WAW, YYZ, LIM).