The scheduled maintenance has been completed. All services are operational since 19:00 UTC.
Posted Mar 17, 2025 - 20:37 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 17, 2025 - 13:08 UTC
Scheduled
As part of our continuous improvement plan, maintenance is scheduled for update the Internal databases on BHS3.
Start time : 17/03/2025 13:00 UTC End time : 17/03/2025 19:00 UTC Service impact : None Service improvement : As part of our continuous improvement policy, we will be doing a public cloud service maintenance.
Thank you for your understanding.
Posted Feb 14, 2025 - 02:04 UTC
This scheduled maintenance affected: Network || Public network (BHS3).